httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Covener <cove...@gmail.com>
Subject Re: [users@httpd] Using requestheader to insert new header=environmentvariable_value
Date Thu, 23 Feb 2012 11:54:35 GMT
On Thu, Feb 23, 2012 at 4:39 AM, Andres Aguado <andriu.one@gmail.com> wrote:
> Hi all,
>
>    Let me ask a short cuestion for help about my virtual host, that i
> think it's not working
>
>   Here is my virtual host:
>
>   RequestHeader set NEW_HEADER env=%{ENV_VARIABLE}e
>   ProxyPass /path http://destination_apphost
>   ProxyPassReverse /path http://destination_apphost
>
>   So, when i connect to www.myvhost.com from my computer, an
> application will process my request and create an environment variable
> (ENV_VARIABLE) with information that i want to send to destination
> application host through http headers (NEW_HEADER).
>
> Do you know if this configuration should work?, because i'm sniffing
> traffic with WireShark and i'm not able to see NEW_HEADER anywhere
>

What applicationsis running before the request is proxied?  The
operative part is to look at when mod_headers will try to read the
environment variable, which is probably before you'll set it.  You can
see when modules run in mod_info.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message