httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andres Aguado <andriu....@gmail.com>
Subject [users@httpd] Reverse proxy problem
Date Thu, 16 Feb 2012 14:31:37 GMT
Hi all, i'd like to expose my problem because i'm going crazy, and if
anyone could help me it'll be very appreciated.

Well, I've an apache 2.2 server over win2k8, and i want to configure
it as reverse proxy to send request to backend Websphere server

So, my httpd.conf file is written like this:

NameVirtualHost *:80
<VirtualHost *:80>
      DocumentRoot "C:\Program Files (x86)\Apache Software
Foundation\Apache2.2\htdocs\my_example"
      ServerName www.my_example.es:80
      ServerRoot "C:\Program Files (x86)\Apache Software Foundation\Apache2.2"
      DirectoryIndex index.html
      Redirect / https://www.my_example.es:8443
      ErrorLog "C:\Program Files (x86)\Apache Software
Foundation\Apache2.2\logs\error.log"
      TransferLog "C:\Program Files (x86)\Apache Software
Foundation\Apache2.2\logs\access.log"

      ProxyRequests Off
</VirtualHost>

And i've configured virtual host on 8443 in httpd-ssl.conf like this:

<VirtualHost _default_:8443>
      DocumentRoot "C:\Program Files (x86)\Apache Software
Foundation\Apache2.2\htdocs\my_example"
      DirectoryIndex index2.html
      ServerName www.my_example.es:8443
      ServerAdmin admin@my_example.es
      ErrorLog "C:\Program Files (x86)\Apache Software
Foundation\Apache2.2\logs\error.log"
      TransferLog "C:\Program Files (x86)\Apache Software
Foundation\Apache2.2\logs\access.log"

      ProxyRequests Off
      ProxyPreserveHost On
      ProxyPass / https://192.168.112.57
      ProxyPassReverse / https://192.168.112.57
</VirtualHost>

Proxy modules enabled are mod_proxy.so and mod_proxy_http.so
But this configuration is not working.

If i comment both proxypass sentences and try, it connects to local
index.html page, but if i enable proxypass sentences, it tries to
connect, typical website certificate error (continue to this site)
appears in iexplorer and internal server error page is displayed.

Could anyone help me please?

Thank you very much
Andres

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message