httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zaxy <zax...@gmail.com>
Subject Re: [users@httpd] Make error, apache 2.4.1
Date Thu, 23 Feb 2012 17:46:10 GMT
On 23.02.2012 16:11, Zaxy wrote:
>> Hi,
>>
>> first time posting here.
>>
>> Before I go to my problem, let me just clarify that I did everything
>> in my power to solve it before writing here.
>>
>> The problem is as follows:
>>
>> After a successful ./configure --prefix=/usr/local/apache2.4.1
>> the "make" command exits with an error.
>>
>> Making all in srclib
>> make[1]: Entering directory `/usr/local/src/httpd-2.4.1/srclib'
>> Makefile:49: *** missing separator. Stop.
>> make[1]: Leaving directory `/usr/local/src/httpd-2.4.1/srclib'
>> make: *** [all-recursive] Error 1
>>
>> 49th line of srclib/Makefile:
>>
>> @INCLUDE_RULES@
>>
>> The system is Ubuntu 11.04 32-bit.
>>
>> I would really appreciate any ideas. If I need to post more
>> information, I will do so gladly.
>
> The line you quoted is expected in a Makefile coming from the apr 
> library (or apr-util). Such a Makefile is not expected in srclib, but 
> insteadf in srclib/apr resp. srclib/apr-util.
>
> So if you tell us how you try to build, we might be able to guide you.
>
> - Where is your apr and apr-util? If you added it to srclib, how 
> exactly did you do that?

They are both in srclib located in srclib/apr and srclib/apr-util.

Basically I downloaded them from apr.apache.org, extracted, copied into 
srclib, then renamed to apr/apr-util to remove the versions.

I double checked that files are actually in the srclib/apr/ directory, 
not in the srclib/apr/apr-1.6.4 dir or something else.

> - is the above configure command complete, ie.e. you didn't give 
> additional flags like telling configure where your apr is?

I tried with --with-included-apr flag but got this make error. Then I 
thought I'd try without the flag and got the same result.

> - if the line is complete, do your have the approprite apr and 
> apr-util versions installed in your system default library location?

To be honest, I have no idea how to install it. So my guess would be 
that I don't.

> - did configure complain about anything (and you tried to call "make" 
> nevertheless) - rephrased: is there a way you can post your configure 
> output?

I didn't notice any errors in configure. The whole configure output can 
be found here: http://pastebin.com/3t1BrsvH

Thank you for your response!

>
> ...
>
> Regards,
>
> Rainer
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server 
> Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>

Regards,

M.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message