httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan-Hendrik Palic <billgot...@ki.tng.de>
Subject [users@httpd] apache 2.2.14 with ChrootDir, mod_fcgi, php5 on Ubuntu 10.04
Date Thu, 02 Feb 2012 11:04:49 GMT
Hi there,

I try to get a chrooted apache working on Ubuntu 10.04 LTS (in a test 
case on 32Bit).

The features I want to provide are

- chrooted (with the core feature, not mod_chroot),
- fastcgi
   - using php5, python, perl, cgi ...
- suexec

Everything runs fine with static content.

Running my index.php including phpinfo(), I fought against several problems.
The last one I can't solve is the following:

error.log:
[Wed Feb 01 23:20:29 2012] [debug] fcgid_proc_unix.c(548): [client 
82.97.146.70] (2)No such file or directory: mod_fcgid: can't connect 
unix domain socket: /var/lib/apache2/fcgid/sock/22409.40
[Wed Feb 01 23:20:33 2012] [warn] [client 82.97.146.70] mod_fcgid: can't 
apply process slot for /00/100100/htdocs/index.php
[Wed Feb 01 23:20:33 2012] [debug] mod_deflate.c(615): [client 
82.97.146.70] Zlib: Compressed 406 to 275 : URL /index.php

suexec.log:
[2012-02-01 23:20:29]: uid: (10000/jpa100) gid: (10000/jpa100) cmd: 
php5-fcgi-starter

ChrootDir is set to /storage/01
suexec's userdir is set to /storage/01

My VHostconfig:
<VirtualHost *:80>
     ServerAdmin jpalic@ennit.de
     ServerName jpatest100.tng.de
     SuexecUserGroup jpa100 jpa100
     AddHandler fcgid-script .php
     DocumentRoot /00/100100/htdocs
     DirectoryIndex index.htm index.html index.php
<Directory />
     Options FollowSymLinks
     AllowOverride None
</Directory>
<Directory "/00/100100/htdocs">
     Options Indexes MultiViews FollowSymLinks +ExecCGI
     FCGIWrapper /storage/01/00/100100/php-fcgi/php5-fcgi-starter .php
     Order allow,deny
     allow from all
</Directory>
ErrorLog /var/log/apache2/jpatest100.tng.de.error.log
LogLevel debug
CustomLog /var/log/apache2/jpatest100.tng.de.access.log combined
ServerSignature On
</VirtualHost>

If the path in the FCGIWrapper line is set to its relative path, apache 
is complaining about missing the directory before it starts.

May anyone give me a hint, please?

Thank you in advance.

Jan

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message