httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Noel Butler <noel.but...@ausics.net>
Subject Re: [users@httpd] apache 2.4 access controls and requires
Date Tue, 28 Feb 2012 05:34:35 GMT
On Mon, 2012-02-27 at 18:37 +1000, Nick Edwards wrote:

> I note that the allow/deny old method is deprecated, but I find the
> lack of examples problemsome in trying to convert to the newer method,
> which I guess we should be doing to avoid bad habbits.
> 
> DIR
>      Order allow,deny
>         Allow from 1.2.0 127.0.0.1
>         Satisfy any
>         ...auth DB stuff ...
>         Require valid-user
> /DIR
> 
> How would I write this?
> 
> DIR
> Require all denied
> require ip 1.2.0  127.0.0.1
> require valid-user
> /DIR
> 


Close, you don't need the preceding "require all denied"  once you use a
require blah, it infers everything else is opposite, therefore denied.




Mime
View raw message