httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bardo Bakker <bardobak...@gmail.com>
Subject Re: [users@httpd] Proces killed after http post without ConentType header
Date Sun, 29 Jan 2012 11:36:54 GMT
Tanx for reply!

In run on CentOS 5.7 (Latest). CentOS' policy is to have most stable
versions which is apache 2.2.3... And this is not stable behaviour.

PHP Version => 5.3.9
mysql  Ver 14.14 Distrib 5.5.20, for Linux (x86_64) using readline 5.1

Acording to this version info only my httpd is a out of date but should be
stable.

2012/1/29 Yehuda Katz <yehuda@ymkatz.net>

> On Sat, Jan 28, 2012 at 7:16 AM, Bardo Bakker <bardobakker@gmail.com>wrote:
>
>> Hi,
>>
>> I wrote some software which post a binary (image) to our server.
>> After a reboot (due to resize HDD), the server has some post issues.
>> It hangs at the end of a http post without the content type header set.
>>
>> I would like to know: is this a bug, configuration mistake, or miss
>> interpertation of http post protocol...
>>
>> Tank you!
>>
>>
>>
>> Version apache:
>> [root@www ~]# /usr/sbin/httpd -V
>> Server version: Apache/2.2.3
>>
> This is a very old version with known security issues. You should upgrade.
>
>
>> On kill/error/fault I found in error_log:
>>
>> Sat Jan 28 12:56:09 2012] [notice] child pid 17077 exit signal
>> Segmentation fault (11), possible coredump in /tmp
>>
>> So made a coredump: gdb: bt all:
>>
>> Core was generated by `/usr/sbin/httpd -k start'.
>> Program terminated with signal 11, Segmentation fault.
>> #0  0x00007fe25c5696c0 in zend_hash_num_elements () from
>> /etc/httpd/modules/libphp5.so
>>
> Pretty obvious that the problem is with PHP. My guess is that you updated
> some library on the system (maybe MySQL) and PHP is now first trying to use
> it.
> You did not include which PHP version you are using. I suggest you check
> your php configuration.
> As long as you are not using different configuration files for mod_php and
> php-cli, you should be able to run "php -i" to check that PHP is working
> properly.
>
> - Y
>

Mime
View raw message