httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Evans <tevans...@googlemail.com>
Subject Re: [users@httpd] Compile Apache 2.2.21 with proxy-html
Date Fri, 20 Jan 2012 10:59:30 GMT
On Fri, Jan 20, 2012 at 10:47 AM, Stephane Eybert
<mittiprovence@yahoo.se> wrote:
>
> Hi,
>
> I run Linux Mint 11 Katya and installed the libapache2-mod-proxy-html
> library
>
> stephane-ThinkPad-T43 stephane # apt-cache show libapache2-mod-proxy-html
> Package: libapache2-mod-proxy-html
> [... ]
>

This installs mod_proxy_html into the system apache modules directory.

> Now, I'm trying to compile my Apache httpd-2.2.21 with it:
>
>
>
> stephane@stephane-ThinkPad-T43:httpd-2.2.21> ./configure
> --prefix=/home/stephane/programs/install/apache --enable-module=so
> --enable-libgcc --enable-module=most --enable-shared=max
> --enable-module=rewrite --enable-proxy --enable-proxy-http
> --enable-proxy-html --enable-proxy-connect --enable-proxy-balancer
> --enable-proxy-ajp
>

This installs a custom build of apache into the specified prefix.

> The configure, make and make install run fine without any error messages.
>
> But the module is no where to be seen:
>

This is because it is installed into a different location.

I don't understand why you are installing an apache module from your
distribution, and apache itself from source. Either install both from
source, or install both from your distribution.

Cheers

Tom

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message