httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin A. McGrail" <KMcGr...@PCCC.com>
Subject Re: [users@httpd] Basic Auth Authentication Wonkiness with scripts or Static HTML not protected by Basic Auth accessing resources protected by Basic Auth In when using Apache & Internet Explorer
Date Mon, 16 Jan 2012 23:35:07 GMT

On 1/16/2012 4:29 PM, Igor Cicimov wrote:
>
>  I have a feeling that IE and FF exibit the same behavor its just that
>  FF automatically supplies the credentials without prompting you all
>  the time.
>
I had similar thoughts.  However, with IE, I typically will get some
password error log entries with firefox.  Something like this even
though I have 100% entered the password correctly:

[Mon Jan 16 15:46:46 2012] [error] [client 129.33.49.252] user pictures:
authentication failure for
"/photos/7/.cache/dba5b12f5ec0bd5edc4505451a87ee4cd15663c7ad672db0afffca6e1aaec04e0ee0a3db6a669a35poac-nova-asnv-holidayparty-2011-DSC_0001-13.jpg-400x400.jpg-100x150.jpg":
Password Mismatch, referer:
http://www.poac-nova.org/photomanager/photomanager-gallery-view.cgi?set=2&gallery=7
>
>  Try putting the htaccess file out of photos directory and enclose the
>  authentication inside Directory tag.
>
Good idea.  Switching from a .htaccess file to using a Basic Auth
directive inside a directory tag in httpd.conf DOES in fact appear to
resolve the issue in IE and firefox.

So have I found a bug or just a known issue?

Regards,
KAM



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message