httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nico Nieuwoudt <nico.nieuwo...@gmail.com>
Subject Re: [users@httpd] Apache not decoding %2f to / in URL
Date Sat, 10 Dec 2011 12:02:11 GMT
I have to use "%2f" in URL and not "/". Idea is to configure apache in such
manner to recognise and encode "%2f" to "/".

Thx
On Dec 10, 2011 1:36 AM, "Eric Covener" <covener@gmail.com> wrote:

> On Fri, Dec 9, 2011 at 6:18 PM, Nico Nieuwoudt <nico.nieuwoudt@gmail.com>
> wrote:
> > Hi
> >
> > I've seen some topics regarding %2f ( URL encoded / ), but still having
> > problem after suggested solutions.
> >
> > I have the following entry in httpd.conf (Apache v2.2)
> >
> > <VirtualHost x.x.xx.xxx:80>
> >     AcceptPathInfo On
> >     AllowEncodedSlashes On
> > </VirtualHost>
> >
> > and after passing an error page URL from httpd.conf, entry:
> > ErrorPage http://x.x.xx.xxx%2ferror.html (which should be encoded as
> > http://x.x.xx.xxx/error.html)
> >
> > I get the follwing from all browsers e.g
> > Firefox can't find the server at x.x.xx.xxx%2ferror.html
>
> Use an actual "/" where it's expected in the URL.
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

Mime
View raw message