httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Evans <tevans...@googlemail.com>
Subject Re: [users@httpd] ReverseProxy is not working
Date Thu, 08 Dec 2011 12:39:21 GMT
On Thu, Dec 8, 2011 at 12:11 PM, KESTAR <perathkarthik@gmail.com> wrote:
>
>
> I installed Apache Httpd server "httpd-2.2.19-win32-x86-openssl-0.9.8r" on
> Windows 2008 Server R2.
>
> I have a java applications deployed in weblogic in another machine. I am
> trying to set up reverse proxy to that application.
>
> This is how I set up ReverseProxy in httpd.conf
>
> ###########################
>
> ProxyRequests Off
> <Proxy *>
> Order deny,allow
> Allow from all
> </Proxy>
>
> NameVirtualHost WIN-9MN2TINIKMO:8090
>
> <VirtualHost WIN-9MN2TINIKMO:8090>
> ServerName WIN-9MN2TINIKMO
> ProxyPreserveHost Off
>        <Location "/oaam_server/">
>        Order deny,allow
>        Allow from all
>        ProxyPass http://172.16.30.189:14300/oaam_server/
>        ProxyPassReverse http://172.16.30.189:14300/oaam_server/
>        </Location>
>        <Location "/ShoppingCart/">
>        Order deny,allow
>        Allow from all
>        ProxyPass http://172.16.30.189:7001/ShoppingCart
>        ProxyPassReverse http://172.16.30.189:7001/ShoppingCart
>        </Location>
>
> </VirtualHost>
>
> ##########################
>
> But when I test configuration with URL as
> http://WIN-9MN2TINIKMO:8090/ShoppingCart, the request is not proxied to the
> application.
>
> In error logs it says...
>
> [Thu Dec 08 16:14:14 2011] [error] [client 172.16.30.105] File does not
> exist: C:/Apache2.2/htdocs/ShoppingCart
> [Thu Dec 08 16:21:06 2011] [error] [client 172.16.30.189] File does not
> exist: C:/Apache2.2/htdocs/favicon.ico
> [Thu Dec 08 16:21:09 2011] [error] [client 172.16.30.189] File does not
> exist: C:/Apache2.2/htdocs/favicon.ico
> [Thu Dec 08 16:21:13 2011] [error] [client 172.16.30.189] File does not
> exist: C:/Apache2.2/htdocs/ShoppingCart
> [Thu Dec 08 16:25:33 2011] [error] [client 172.16.30.105] File does not
> exist: C:/Apache2.2/htdocs/oaam_server
>
> Eventhough I configured proxy as shown above, apache server is looking for
> resources in htdocs only. I also uncommented mod_proxy and mod-proxy_http
> modules in httpd.conf file
>
> Am I missing any other settings??
>
> Pls help http://old.nabble.com/file/p32934121/httpd.conf httpd.conf

You aren't hitting your vhost, and it is being served out of the
default configuration.

Presumably WIN-9MN2TINIKMO is your local machine, and you are
accessing it from that same machine? In which case, WIN-9MN2TINIKMO
resolves to a specific IP, but when you connect to the site from the
same box, it goes over the loopback connection, and so Apache sees the
request as going to 127.0.0.1:8090, which does not match your vhost
specification.

Change these lines:

NameVirtualHost	*:8090
<VirtualHost *:8090>

Cheers

Tom

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message