httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Galić <i.ga...@brainsware.org>
Subject Re: [users@httpd] Getting blog.domain.com instead of domain.com/blog
Date Fri, 25 Nov 2011 17:43:44 GMT


----- Original Message -----
> I am not sure if this is an apache issue or not but i thought i ask
> and see what the experts thought.
> I have a WP blog at domain.com/blog. I want to have people access the
> blog by blog.domain.com. I have public dns entries for
> blog.domain.com that point back to the public ip but this does not
> return the desired results. I created a virtualhost and give the
> serveralias blog.domain.com and the correct directory and get page
> not found. Nothing shows in the error log. Thanks for any help

Redirects in httpd are accomplished with either

Redirect, or sadly, some people also use the muddy [R] from 
mod_rewrite (and implicit mod_rewrite Redirect can also be caused
by adding http:// or https:// to the Target or the rewrite)

If you have any of these in your config or in your .htaccess
then it's httpd's doing. If not, WP is the cuprit.

i

-- 
Igor Galić

Tel: +43 (0) 664 886 22 883
Mail: i.galic@brainsware.org
URL: http://brainsware.org/
GPG: 6880 4155 74BD FD7C B515  2EA5 4B1D 9E08 A097 C9AE


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message