httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ricardo Bayley <ricardo.bay...@gmail.com>
Subject Re: [users@httpd] Proxy Tomcat
Date Sat, 19 Nov 2011 19:17:55 GMT
Hi Alex,

No, I want is this.

request => http://server01/wms?somearguments
converts => http:// server02:8080/gwc/wms?somearguments

This should be proxied, not redirected.

If I do what u mention, dont know why arguments are not sent. I guess you
are not Rewriting anything.


regards,


ricardo



2011/11/19 Alex Samad - Yieldbroker <Alex.Samad@yieldbroker.com>

>  Hi****
>
> ** **
>
> My understanding is that if you have ****
>
>    ProxyPassReverse / http://10.0.0.2:8080/gwc/service/****
>
>    ProxyPass / http://10.0.0.2:8080/gwc/service/****
>
> ** **
>
> ** **
>
> And you make a request for ****
>
> http://reverseproxy/somepage.cgi?somearguments****
>
> ** **
>
> it converts its into ****
>
> ** **
>
> http://reverseproxy/gwc/service/somepage.cgi?somearguments****
>
> ** **
>
> ** **
>
> Which is what you want ?****
>
> ** **
>
> Alex****
>
> ** **
>
> *From:* Ricardo Bayley [mailto:ricardo.bayley@gmail.com]
> *Sent:* Sunday, 20 November 2011 2:12 AM
> *To:* users@httpd.apache.org
> *Subject:* Re: [users@httpd] Proxy Tomcat****
>
> ** **
>
> Hi Alex, and Congo, I dont see how to concat the Proxy http://10.0.0.2/etcwith the "?"
> ****
>
> ** **
>
> Congo, I do have a vhost for every geo service. What I am trying to do is
> to Proxy request using apache. This way I dont have to have all tomcats in
> the open. But as you can see, I am failing to do so. :(****
>
> ** **
>
> So do you have a sample on how to do it ?****
>
> ** **
>
> ** **
>
> regards to both,****
>
> ** **
>
> ** **
>
> Ricardo****
>
> ** **
>
> ** **
>
> ** **
>
> ** **
>
> 2011/11/19 Alex Samad - Yieldbroker <Alex.Samad@yieldbroker.com>****
>
> Hi  ****
>
>  ****
>
> Why not have****
>
>  ****
>
>    ProxyPassReverse / http://10.0.0.2:8080/gwc/service/****
>
>    ProxyPass / http://10.0.0.2:8080/gwc/service/****
>
>  ****
>
> Alex****
>
>  ****
>
> *From:* Ricardo Bayley [mailto:ricardo.bayley@gmail.com]
> *Sent:* Saturday, 19 November 2011 8:54 AM
> *To:* users@httpd.apache.org
> *Subject:* [users@httpd] Proxy Tomcat****
>
>  ****
>
> Hi folks,****
>
>  ****
>
> I am trying to proxy a request.****
>
> I have this input****
>
>  http://someAddress/wms?val1=1&val2=2****
>
>   ****
>
> it should be turned into****
>
>  http://10.0.0.2:8080/gwc/service/wms?val1=1&val2=2****
>
>   ****
>
>    ProxyPassReverse / http://10.0.0.2:8080/****
>
>    ProxyPass / http://10.0.0.2:8080/****
>
>    RewriteEngine On****
>
> # RewriteCond *some condition*****
>
>    RewriteRule   ^/wms(.*)$   http://10.0.0.2:8080/wms%{QUERY_STRING} [P]*
> ***
>
>  ****
>
>  ****
>
> If I write =>  RewriteRule   ^/wms(.*)$   http://10.0.0.2:8080/wms*?*%{QUERY_STRING}
> [P]****
>
> then %{QUERY_STRING} wont be placed.****
>
> But if I don't place the "?" then I am not properly forming the request.**
> **
>
>  ****
>
>  ****
>
> Can anyone help ?****
>
>  ****
>
>  ****
>
> best regards,****
>
>  ****
>
>  ****
>
> Ricardo****
>
> ** **
>

Mime
View raw message