httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harsimranjit singh Kler <simran...@gmail.com>
Subject [users@httpd] Unable to Compile and install Httpd 2.2.17 when enabling openssl
Date Fri, 04 Nov 2011 11:04:51 GMT
hi

i want to enable SSL module along with apache but failed.

i have done following:

1)downloaded openssl-0.9.8k.tar and installed open ssl libararies at
"/usr/local/ssl".


2)Similar downloded fresh setup of httpd-2.2.17.tar.gz

3)running following commands but 'make' throw error:

i)./configure --prefix=/tmp/balancer --enable-mods-shared=all
--with-mpm=worker --disable-cgi --enable-ssl --with-ssl=/usr/local/ssl/
--enable-setenvif

ii)make

--
---
_module
/usr/bin/ld: /usr/local/ssl/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32
against `a local symbol' can not be used when making a shared object;
recompile with -fPIC
/usr/local/ssl/lib/libssl.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[4]: *** [mod_ssl.la] Error 1
make[4]: Leaving directory `/tmp/httpd-2.2.17/modules/ssl'
make[3]: *** [shared-build-recursive] Error 1
make[3]: Leaving directory `/tmp/httpd-2.2.17/modules/ssl'
make[2]: *** [shared-build-recursive] Error 1
make[2]: Leaving directory `/tmp/httpd-2.2.17/modules'
make[1]: *** [shared-build-recursive] Error 1
make[1]: Leaving directory `/tmp/httpd-2.2.17'
make: *** [all-recursive] Error 1
---


installation is successfull if i am running
:./configure --prefix=/opt/nsn/ccsf/applications/balancer --with-mpm=worker
--disable-cgi --enable-ssl --with-ssl=/usr/local/ssl/  --enable-setenvif



please help me out what is right way to enble ssl if i have missed anything?

regards
harsimran

Mime
View raw message