httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Waligora <bmw929...@gmail.com>
Subject Re: [users@httpd] Windows 7 DocumentRoot directive not working
Date Wed, 19 Oct 2011 17:10:06 GMT
I found the issue. I edited the httpd.conf file with textpad. But, textpad
wasn't running as administrator. So, my changes were saved in an unknow user
location. Every time I opened the httpd.conf file, it opened my personal
version instead of the file, not the real file. So, my changes were never
saved. Even though, it appeared to change. Thanks Microsoft. I love opening
a file and having the O.S. open a different file, but not telling me that it
opened a different file.

On Wed, Oct 19, 2011 at 1:02 PM, Serge Fonville <serge.fonville@gmail.com>wrote:

> Hi,
>
> Assuming you restarted apache after changing the httpd.conf..
>
> What output do you get from:
> httpd.exe -S
> sc query | find /i "apache"
> tasklist /fi "Imagename eq httpd.exe" /svc
>
> HTH
>
> Kind regards/met vriendelijke groet,
> Serge Fonville
> http://www.sergefonville.nl
>
> Convince Google!!
> They need to add GAL support on Android (star to agree)
> http://code.google.com/p/android/issues/detail?id=4602
>
>
>
> 2011/10/19 Robert Waligora <bmw929500@gmail.com>:
> > I installed Apache 2.2.21 on Windows 7 machine. Test "It Works" page is
> > displayed. I changed the following in httpd.conf:
> >
> > DocumentRoot "e:/webroot/"
> > <Directory "e:/webroot/">
> >
> > I created "webroot" folder on e drive (also tried with c drive and
> without
> > ending slash).
> > Put a sample index.html file in that folder with a different message
> (i.e.
> > not "It Works").
> > Restarted the Apached service, but still get the "It Works" message. I
> opend
> > my new index.html file will a browser to verify that there are no errors
> > with the html code.
> > I made sure that the is only 1 "DocumentRoot" directive in the httpd.conf
> > file.
> >
> > Access.log file shows that get requests are coming in.
> > Error.log file doesn't show any error messages
> >
> > Any ides?
> > --
> > Robert Waligora ~ http://www.waligora.com
> > Cell Phone: 440-941-2262 (new cell phone number)
> > Home Phone: 440-519-0733
> >
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


-- 
Robert Waligora ~ http://www.waligora.com
Cell Phone: 440-941-2262 (new cell phone number)
Home Phone: 440-519-0733

Mime
View raw message