httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Montague <m...@catseye.org>
Subject Re: [users@httpd] wbsite takes time to load
Date Thu, 13 Oct 2011 13:58:09 GMT
On October 13, 2011 5:54 , "Amira Othman" <a.othman@cairosource.com> wrote:
>
>
> I am using httpd-2.2.3-53.el5.vm on CentOS 5.6. i am new to apache 
> .today when I tried to access my website I found that it takes too 
> long time to load .i don’t know where to start investigating. As there 
> is nothing wrong with log file. Any help for me??
>

Does your website take too long to load because your web server is slow, 
or because the page is inefficiently rendered by the web browser? Or 
because of both reasons?

Add %D to your LogFormat or CustomLog directive to get an idea of how 
long each request takes to serve. Make sure each individual request is 
completed quickly. The biggest single source of slowness is usually 
active content (for example, poorly written PHP), but see 
https://httpd.apache.org/docs/2.2/misc/perf-tuning.html for a list of 
ways you can improve serving static content.

If each individual request is being completed quickly by the web server, 
then the problem is probably that the content of your pages is being 
rendered slowly by web browsers. Use tools such as Yahoo YSlow ( 
http://developer.yahoo.com/yslow/help/ ), Google Page Speed ( 
https://code.google.com/speed/page-speed/ ), and the Timeline tool in 
Safari's Web Inspector in order to find out how your web browser is 
spending its time.

--
   Mark Montague
   mark@catseye.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message