httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jakov Sosic <jakov.so...@srce.hr>
Subject [users@httpd] Program terminated with signal 7, Bus error.
Date Mon, 01 Aug 2011 15:21:52 GMT
Hi.

I run RHEL v5.6 and can see this kind of entries in my apache error_log:

[Sun Jul 31 23:27:44 2011] [notice] child pid 6974 exit signal Bus error
(7), possible coredump in /tmp/httpd-gdb-dump
[Sun Jul 31 23:27:44 2011] [notice] child pid 6976 exit signal Bus error
(7), possible coredump in /tmp/httpd-gdb-dump
[Sun Jul 31 23:27:44 2011] [notice] child pid 6979 exit signal Bus error
(7), possible coredump in /tmp/httpd-gdb-dump


I've turned on coredump as you can see, and installed lots of debuginfo
packages (although not all of them).


After the core is generated, this is what I get with gdb:

warning: no loadable sections found in added symbol-file system-supplied
DSO at 0x7ffff930f000
Core was generated by `/usr/sbin/httpd'.
Program terminated with signal 7, Bus error.
#0  0x00002b66739c139b in memcpy () from /lib64/libc.so.6
(gdb) bt
#0  0x00002b66739c139b in memcpy () from /lib64/libc.so.6
#1  0x00002b6677e46584 in php_ob_append (str=0x2b6685903000 <Address
0x2b6685903000 out of bounds>, str_length=2270) at
/usr/include/bits/string3.h:51
#2  php_b_body_write (str=0x2b6685903000 <Address 0x2b6685903000 out of
bounds>, str_length=2270) at /usr/src/debug/php-5.3.3/main/output.c:682
#3  0x00002b6677e4a7ba in _php_stream_passthru (stream=0x2b667ea474b8)
at /usr/src/debug/php-5.3.3/main/streams/streams.c:1220
#4  0x00002b6677de0839 in zif_readfile (ht=<value optimized out>,
return_value=0x2b667ea4a2c8, return_value_ptr=<value optimized out>,
    this_ptr=<value optimized out>, return_value_used=<value optimized
out>) at /usr/src/debug/php-5.3.3/ext/standard/file.c:1442
#5  0x00002b667d2458ad in phar_readfile (ht=1,
return_value=0x2b667ea4a2c8, return_value_ptr=0x0, this_ptr=0x0,
return_value_used=0)
    at /usr/src/debug/php-5.3.3/ext/phar/func_interceptors.c:320
#6  0x00002b6677ed27c9 in zend_do_fcall_common_helper_SPEC
(execute_data=0x2b667eedc050) at
/usr/src/debug/php-5.3.3/Zend/zend_vm_execute.h:316
#7  0x00002b6677ea888b in execute (op_array=0x2b66808c0f80) at
/usr/src/debug/php-5.3.3/Zend/zend_vm_execute.h:107
#8  0x00002b6677e84e35 in zend_execute_scripts (type=8, retval=0x0,
file_count=3) at /usr/src/debug/php-5.3.3/Zend/zend.c:1194
#9  0x00002b6677e35d28 in php_execute_script
(primary_file=0x7ffff9284b40) at /usr/src/debug/php-5.3.3/main/main.c:2260
#10 0x00002b6677f0d52d in php_handler (r=0x2b6686b30100) at
/usr/src/debug/php-5.3.3/sapi/apache2handler/sapi_apache2.c:669
#11 0x00002b6671a45a0a in ap_run_handler (r=0x2b6686b30100) at
/usr/src/debug/httpd-2.2.3/server/config.c:157
#12 0x00002b6671a48e98 in ap_invoke_handler (r=0x2b6686b30100) at
/usr/src/debug/httpd-2.2.3/server/config.c:375
#13 0x00002b6671a53938 in ap_process_request (r=0x2b6686b30100) at
/usr/src/debug/httpd-2.2.3/modules/http/http_request.c:258
#14 0x00002b6671a50b70 in ap_process_http_connection (c=0x2b6686b1dee0)
at /usr/src/debug/httpd-2.2.3/modules/http/http_core.c:184
#15 0x00002b6671a4cc92 in ap_run_process_connection (c=0x2b6686b1dee0)
at /usr/src/debug/httpd-2.2.3/server/connection.c:43
#16 0x00002b6671a577e9 in child_main (child_num_arg=<value optimized
out>) at /usr/src/debug/httpd-2.2.3/server/mpm/prefork/prefork.c:640
#17 0x00002b6671a57a7a in make_child (s=0x2b6671c99d70, slot=26) at
/usr/src/debug/httpd-2.2.3/server/mpm/prefork/prefork.c:736
#18 0x00002b6671a582dd in ap_mpm_run (_pconf=<value optimized out>,
plog=<value optimized out>, s=<value optimized out>)
    at /usr/src/debug/httpd-2.2.3/server/mpm/prefork/prefork.c:871
#19 0x00002b6671a32e48 in main (argc=1, argv=0x7ffff9285138) at
/usr/src/debug/httpd-2.2.3/server/main.c:717
(gdb) quit



Is there any way I can debug this any further? Crashes occur randomly,
and apache service is not affected, pages are being served regulary
before and after this kind of errors. Hardware is out of question
because I have this problem on more than one server...


Any idea what to do next?


-- 
Jakov Sosic
www.srce.hr

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message