httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diego Maciel Gomes <diego.go...@cecred.coop.br>
Subject [users@httpd] apache + AD auth
Date Tue, 30 Aug 2011 18:08:43 GMT
Hello All...

I have auth against AD...

It was working fine, in a good day, it stops to work, and I have no idea why it doesnt work
now...

So, Im using windows 2008 R2 for windows and httpd-2.2.3-53 red hat OK?

this is my conf inside the virtualhost:

        AuthBasicProvider ldap
        AuthType Basic
        AuthzLDAPAuthoritative off
        AuthName "*** Cuidado - Acesso Restrito ***"
        AuthLDAPURL "ldap://domain.com:389/dc=domain,dc=com?sAMAccountName?sub?(objectClass=*)"
        AuthLDAPBindDN "CN=user_read_ad, OU=People, DC=domain, DC=com"
        AuthLDAPBindPassword pass_user_above
        Require ldap-group "CN=group_access, OU=Group, DC=domain, DC=com"

I know that need to set this value below inside the /etc/openldap/ldap.conf :

REFERRALS off

when I access the directory, its calling the auth. I put my user that have privileges, and
I get the error: "500 Internal Server Error" and in the log, i have this:

[Tue Aug 30 14:55:23 2011] [warn] [client 192.168.1.1] [32013] auth_ldap authenticate: user
my_user authentication failed; URI /files [ldap_search_ext_s() for user failed][Operations
error]

Anyone have any idea??

Thanks anyway,

Diego


-- 
Esta mensagem foi verificada pelo sistema de antivirus e
 acredita-se estar livre de perigo.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message