httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zavelo...@gmail.com
Subject Re: Re: [users@httpd] PHP Parsing Problem
Date Thu, 16 Jun 2011 17:06:32 GMT
Any php file that I try to open, including the one containing phpinfo(),  
which is called testphp.php in my case, causes Firefox to ask me what I  
want it to do with the file.

On , zeek <zeek@mogwai.ath.cx> wrote:




> Try the info.php test:




> phpinfo();

> ?>







> On Wed, Jun 15, 2011 at 10:57:10PM -0700, Xavier Lopez wrote:

> > Dear Users,

> >

> > I'm still not getting Apache to parse PHP. I've learned a lot though,

> > here's what I know:

> >

> > In apache2.conf, there are these lines:

> >

> > Include /etc/apache2/mods-enabled/*.load

> > Include /etc/apache2/mods-enabled/*.conf

> >

> > When I run ls /mods-enabled, I see php5.conf and php5.load, among  
> others,

> > And when I run cat 'php5.load', I see LoadModule php5_module

> > /usr/lib/apache2/modules/libphp5.so.

> >

> > Do these facts, taken together, not mean that PHP5 is installed,

> > available, and enabled?

> >

> > Shouldn't Apache therefore parse PHP?

> >

> > When I run apache2ctl -L. I don't see the string 'PHP' anywhere in the

> > output. Should I?

> >

> > When I run a2enmod php5, it says it's already enabled.

> >

> > This is my Virtual Host configuration:

> >

> >

> > ServerName http://testing.dev

> > ServerAdmin webmaster@localhost

> > DocumentRoot /home/zave/Public/testing

> >

> > SetHandler application/x-httpd-php

> >

> >

> > Options FollowSymLinks

> > AllowOverride None

> >

> >

> > Options Indexes FollowSymLinks MultiViews

> > AllowOverride None

> > Order allow,deny

> > allow from all

> >

> >

> > ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

> >

> > AllowOverride None

> > Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch

> > Order allow,deny

> > Allow from all

> >

> >

> >

> > Does anyone see what is preventing PHP from being parsed? I'm running

> > Apache 2.2.14/Ubuntu 10.04, LAMP Install. Thanks for your help thus

> > far.

> >

> > -Xavier

> >

> > ---------------------------------------------------------------------

> > The official User-To-User support forum of the Apache HTTP Server  
> Project.

> > See http://httpd.apache.org/userslist.html> for more info.

> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org

> > " from the digest: users-digest-unsubscribe@httpd.apache.org

> > For additional commands, e-mail: users-help@httpd.apache.org



> ---------------------------------------------------------------------

> The official User-To-User support forum of the Apache HTTP Server Project.

> See http://httpd.apache.org/userslist.html> for more info.

> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org

> " from the digest: users-digest-unsubscribe@httpd.apache.org

> For additional commands, e-mail: users-help@httpd.apache.org




Mime
View raw message