httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xavier Lopez <zavelo...@gmail.com>
Subject [users@httpd] PHP Parsing Problem
Date Thu, 16 Jun 2011 05:57:10 GMT
Dear Users,

I'm still not getting Apache to parse PHP. I've learned a lot though,
here's what I know:

In apache2.conf, there are these lines:

Include /etc/apache2/mods-enabled/*.load
Include /etc/apache2/mods-enabled/*.conf

When I run  ls /mods-enabled, I see php5.conf and php5.load, among others,
And when I run cat 'php5.load', I see LoadModule php5_module
/usr/lib/apache2/modules/libphp5.so.

Do these facts, taken together, not mean that PHP5 is installed,
available, and enabled?

Shouldn't Apache therefore parse PHP?

When I run apache2ctl -L. I don't see the string 'PHP' anywhere in the
output. Should I?

When I run a2enmod php5, it says it's already enabled.

This is my Virtual Host configuration:

<VirtualHost *:80>
        ServerName http://testing.dev
        ServerAdmin webmaster@localhost
        DocumentRoot /home/zave/Public/testing
        <FilesMatch "\.ph(p[2-6]?|tml)$">
           SetHandler application/x-httpd-php
        </FilesMatch>
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/zave/Public/testing>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>


Does anyone see what is preventing PHP from being parsed? I'm running
Apache 2.2.14/Ubuntu 10.04, LAMP Install. Thanks for your help thus
far.

-Xavier

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message