httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J. Stephens" <onlineworkm...@gmail.com>
Subject Re: [users@httpd] 403 error on Default Directory
Date Mon, 02 May 2011 01:52:24 GMT
I think I found the real issue. 

In the vhosts it has 

    RewriteEngine on
    RewriteCond %{HTTP_HOST}   ^test.remcycle.net [NC]
    RewriteRule   ^/(.*)$ /$1  
    RewriteCond %{HTTP_HOST}   ^www.test.remcycle.net [NC]
    RewriteRule   ^/(.*)$ /$1  

After removing this and restarting the website seems to work. I will be doing a little reading
on the rewrite engine to find out why this causes the 403 error, but I believe this to be
the root cause of the issue.



On May 1, 2011, at 7:01 PM, Eric Covener wrote:

> On Sun, May 1, 2011 at 5:13 PM, J. Stephens <onlineworkmail@gmail.com> wrote:
>> I know I should add the root directory due to security, but I am getting
>> this error.
>> website error.log:
>> 
>> Thu Mar 24 19:23:05 2011] [error] [client 98.226.168.246] client denied by
>> server configuration: /
>> 
>> I guess I need to be asking why it needs access to the root of the computer
>> and not just the website directory.
> 
> It doesn't.  That's a URL in the error message, not the root of your filesystem.
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 


Mime
View raw message