httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From TRAFx Research <tr...@trafx.net>
Subject [users@httpd] Dropped packets and 408 responses
Date Mon, 09 May 2011 19:01:46 GMT
Hello everyone,

  We've got a customer that's got a flakey network that's dropping
packets.  This has resulted in a few weird errors coming out of our
Apache setup that I'm trying to work out if I can tweak to avoid.

  The sequence of events is essentially:

    1) Client issues a POST from a file upload form.  All headers
arrive in the first packet, but no request body yet.
    2) There is a pause of 10 seconds, no further data arrives
    3) Apache issues a "302 Found" response
    4) A few seconds later, we finally get packets for the original
request body, flagged as TCP retransmissions, so the originals were
sent, but got lost
    5) Apache now complains with "501 Invalid Method" and this is what
our customer ends up seeing in their browser.

  Issue 47087 (https://issues.apache.org/bugzilla/show_bug.cgi?id=47087)
explains why I get the 501 at the end (fallback to HTTP/0.9)

  The question is, why is Apache returning the "302 Found" response
rather than a "408 Client timeout" in step 3?  The POST issued in step
1 has the appropriate Content-Length header.  The timing of the "302
Found" response doesn't seem to align with the values of "Timeout" or
"KeepAliveTimeout" that I have configured (15 sec and 300 sec).

  Has anyone seen this sequence of events before and knows a
workaround to avoid it?

daniel

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message