httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Hubbard <dhubb...@dino.hostasaurus.com>
Subject [users@httpd] Weird error in error_log -> sh: /which: No such file or directory
Date Wed, 02 Mar 2011 21:30:26 GMT
I'm seeing this in the error_log file:

sh: /which: No such file or directory

fairly frequently.  Server is centos 5.5 with current
centos rpm of apache 2.2.3.  The server is running the
plesk control panel so there are lots of various include
files that make up the apache config.

That error seems to occur a random amount of time after
the server has been started and then continues to occur
maybe every ten or fifteen minutes.

I've tried to strace the main httpd and child processes
but can't find any execve that involves "which" or sh.
I checked for /sh and which in all the domain-level
config files and everything under /etc/httpd/ and no
matches.  

Any ideas on how I can track it down?  I'm assuming it's
outputting that each time a child restarts and reads
some config somewhere that it doesn't like.

Thanks,

David

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message