httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Theman <xray...@hotmail.com>
Subject [users@httpd] Apache crashes when using LDAP auth: child pid 25625 exit signal Segmentation fault (11)‏
Date Thu, 17 Mar 2011 19:09:56 GMT




 Hello,

I built apache as below. 

./configure --prefix=/usr/local/apache2 --with-ssl=/u01/fipsssl 
--enable-ssl -with-ldap --enable-ssl --enable-authnz-ldap --enable-ldap 
--with-mpm=prefork


mod_ssl/2.2.17 compiled against Server: Apache/2.2.17, Library: OpenSSL/0.9.8r-fips

Everything
 works fine, except when I go to do ldap authentication. The browser 
pops up a username/password window, I enter my username/password and 
then hit submit.... I get back "Internet Explorer cannot display the webpage" and in the error
log I see the below segmentation fault.... but if I turn of ldap it works fine...:

Thu Mar 17 14:47:04 2011] [info] [client 129.6.84.222] Connection to child 2 established (server
acctnew.nist.gov:7100)
[Thu Mar 17 14:47:04 2011] [info] Seeding PRNG with 136 bytes of entropy
[Thu Mar 17 14:47:04 2011] [info] Initial (No.1) HTTPS request received for child 2 (server
acctnew.nist.gov:7100)
[Thu
 Mar 17 14:47:04 2011] [info] [client 129.6.84.222] Connection closed to
 child 2 with unclean shutdown (server acctnew.nist.gov:7100)
[Thu Mar 17 14:47:10 2011] [info] [client 129.6.84.222] Connection to child 3 established
(server acctnew.nist.gov:7100)
[Thu Mar 17 14:47:10 2011] [info] Seeding PRNG with 136 bytes of entropy
[Thu Mar 17 14:47:10 2011] [info] Initial (No.1) HTTPS request received for child 3 (server
acctnew.nist.gov:7100)
[Thu Mar 17 14:47:11 2011] [notice] child pid 25625 exit signal Segmentation fault (11)

Thank you for any help!
Sam
 		 	   		  
Mime
View raw message