httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Ross <apache....@bustspammers.com>
Subject Re: [users@httpd] Fails to load xdebug - why?
Date Fri, 11 Mar 2011 23:27:37 GMT
On Mar 9, 2011, at 08:07 , Igor Galić wrote:
> ----- Original Message -----
>> I'm trying to install the debugger extension Xdebug
>> http://xdebug.org/
>> for PHP on the preinstalled Apache 2.0 running on my local Mac. I
>> tried the built-in PHP installation and also the Entropy PHP package
>> http://www.entropy.ch/software/macosx/php/
>> I got the extension from the Xebug site and also a precompiled
>> version from Komodo http://code.activestate.com/komodo/
>> remotedebugging/  It's a PPC Mac and the extension is said to be
>> universal binary, i.e. works on PPC Macs.
>>
>> Xdebug never shows up in the phpinfo(); output, even though it loads
>> the correct php.ini file (double-checked in output) and the .ini file
>> specifies the extension correctly.
>
>
> Hi Steven,
>
> I'm not entirely sure we can help you in this regard.
> None of the above is in any way httpd centric. It's either a problem
> specific to Mac OS X, or specific to Xdebug on OS X.

I think this may be an Apache issue because I tried two different PHP  
builds and two different Xdebug builds, all fail the same way and the  
only constant is the Mac OS built-in Apache.


> In any case the Xdebug or PHP folks can help you:
>
> http://www.xdebug.org/support.php
> http://php.net/mailing-lists.php

I tried the Xdebug mailing list, but no reply.


>> No matter what PHP/Xdebug combo, when I restart Apache, I see
>> something like this in my Apache error log:
>>
>> [Fri Mar 04 12:26:49 2011] [warn] Init: Session Cache is not
>> configured [hint: SSLSessionCache]
>> Failed loading /usr/local/php5/lib/php/extensions/no-debug-non-
>> zts-20060613/xdebug.so: (null)
>
> Two things come to my mind: You're running httpd worker? PHP is
> compiled with threading support (ZTS)?

Sorry, you got me there. I have no idea. It's the Apache that comes  
with every Mac OS X, in my case Apache 2.0 preinstalled in Mac OS X  
10.5.8. It's a worker in that it (usually) works :-) but somehow I  
think that's not what you mean.

Same for PHP - built-in PHP 5.2.14.  phpinfo() doesn't mention  
anything about ZTS. I also tried PHP 5.2.9 from Entropy (see above)  
that others have reported as working with Xdebug.


> Are you loading xdebug as
> zend_extension=/usr/local/php5/lib/php/extensions/no-debug-non- 
> zts-20060613/xdebug.so
> or as
> extension=xdebug.so

Yes, as zend_extension. this is my complete php.ini:
============================
zend_extension = /usr/lib/php/extensions/no-debug-non-zts-20060613/ 
xdebug.so
xdebug.remote_enable=on
xdebug.remote_log="/var/log/xdebug.log"
xdebug.remote_host=localhost
xdebug.remote_handler=dbgp
xdebug.remote_port=9000
============================
xdebug.so is present at the extension path, but I notice your path is  
different. Should it make a difference whether everything is under / 
usr/local vs. /usr/lib?

I noticed if I remove the extension from the directory, the error log  
entry for the missing file is exactly the same:
Failed loading ... (null)
But in my case it's not a missing file. Is there a way to make those  
messages more verbose?
---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message