httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Theman <xray...@hotmail.com>
Subject RE: [users@httpd] How do you build apache 2.2.17 with openssl FIPS ???
Date Wed, 09 Feb 2011 20:52:05 GMT


When I boot with SSLFIPS off, I see this in my log:

[Wed Feb 09 15:50:10 2011] [notice] Apache/2.2.17 (Unix) mod_ssl/2.2.17 OpenSSL/FIPS configured
-- resuming normal operations

I have compiled in openSSL FIPS, but why doesn't 2.2.17 recognize it as such?

Sam

From: xray316@hotmail.com
To: users@httpd.apache.org
Date: Wed, 9 Feb 2011 12:51:13 -0500
Subject: [users@httpd] How do you build apache 2.2.17 with openssl FIPS ???








Hello,

I am trying to build Apache 2.2.17 on RH linux 5 with openssl FIPS openssl-fips-1.2.2.tar.gz

I built and install openssl fips 1.2.2 and then ran my apache config:

 ./configure --prefix=/usr/local/apache2 --with-ssl=/usr/local/fips_openssl/ssl --with-mpm=prefork
--enable-ssl

I did make, make install and then tried to run my apache with "SSLFIPS on" within my httpd-ssl.conf,
BUT when I try to boot, I get: 

"Syntax error on line 1 of /usr/local/apache2/conf/extra/httpd-ssl.conf:
SSLFIPS invalid, rebuild httpd and openssl compiled for FIPS"

Any ideas?????

Sam




 		 	   		  
Mime
View raw message