httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lee <lee...@gmail.com>
Subject Re: [users@httpd] PCRE Syntax or bug? (was "Require group" help required)
Date Tue, 22 Feb 2011 06:55:49 GMT

> On 21 Feb 2011, at 09:12, Lee Goddard wrote:
>
>> Dear Apache Users,
>>
>> I have been looking at a problem for so many hours now that I think it has made me
blind.
>>
>> The below configuration is intended to restrict access to /admin-cgi/ to members
of the group "admin", which is defined in a plain text file, whilst users and passwords are
in a DBM file.
>> [...]
>>
>>     AuthGroupFile /Users/leegoddard/src/www/northfoto2/auth/northfoto_groups.db

The problem seems to be solved, but the solution does not seem valid.

There appears to have been a conflict between these two groups of 
directives:

ScriptAlias /adminjr-cgi/ 
"/Users/leegoddard/src/www/northfoto2/adminjr-cgi/"
<Directory "/Users/leegoddard/src/www/northfoto2/adminjr-cgi/">
...    Require group admin ...
</Directory>

Conflicted with:

<LocationMatch "/admin/*">

At least, when I changed the latter to the below, all behaved as expected:

<LocationMatch "/admin/index.shtml">
...    Require group adminjr ...
</Location>

Have I misunderstood the PCRE engine, or is this a bug...?

Thanks
Lee





---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message