httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Covener <cove...@gmail.com>
Subject Re: [users@httpd] mod_rewrite woes
Date Thu, 20 Jan 2011 20:15:23 GMT
On Thu, Jan 20, 2011 at 3:10 PM, --[ UxBoD ]-- <uxbod@splatnix.net> wrote:
> ----- Original Message -----
>> Did you set RewriteEngine on?
>>
>> Where do you define your rules? If there's a VirtualHost handling the
>> request, they need to be defined there.
>
> Hello Eric,
>
> Thank you for the response. Yes it is a virtual host and I am using the following directives
for it:
>
> <VirtualHost *:80>
>    ServerAdmin webmaster@somedomain.com
>    DocumentRoot "/www/somedomain.com"
>    <Directory /www/somedomain.com>
>        AllowOverride All
>    </Directory>
>    ServerName www.somedomain.com
>    ServerAlias somedomain.com www.somedomain.co.uk somedomain.co.uk
>    ErrorLog "logs/www.somedomain.com-error.log"
>    CustomLog "logs/www.somedomain.com-access.log" common
> </VirtualHost>
>
> I have hardened Apache though I did try changing the directives in httpd.conf for /www
to have AllowOveride All as-well but to no-avail. It seems odd though that a normal re-direct
is working fine.

Use the RewriteLog to debug.

--
Eric Covener
covener@gmail.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message