httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tapas Mishra <mightydre...@gmail.com>
Subject [users@httpd] invalid response from Proxy dns lookup failure
Date Mon, 10 Jan 2011 07:17:59 GMT
Ok here is a situation  today morning I had rebooted the server and I
observed and I see response for one of the application complaining
http://myserver.com/app1

This is the error I see in browser

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /app1.

Reason: DNS lookup failure for: myserver.com

Where as if I were to check only http://myserver.com

then I can see every thing very properly without any error.

Here is my apache2 configuration

http://pastebin.com/aXceB1wt

here is access log on the server which is front end (acts as reverse proxy)

http://pastebin.com/tggRRY2E
and error log on reverse proxy server
http://pastebin.com/vGQZS4xb

and the server  where the application is actually hosted  I do not see
any log which can help me to understand that the request /app1
actually reached there.
How ever I tried to see the http headers in http_live
here they are
http://pastebin.com/QX2FeUtp

So what can this error be pointing to ?
Since until 2-3 days back every thing was working perfectly with same
settings and same configurations.
Today I had restarted server after many days just for maintenance and
after reboot
 I find all applications except the one which I pointed here working properly.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message