httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Galić <i.ga...@brainsware.org>
Subject Re: [users@httpd] Filters not applied with ErrorDocument pages?
Date Mon, 06 Dec 2010 19:40:55 GMT

----- "Dennis Jacobfeuerborn" <dennisml@conversis.de> wrote:

> I just noticed that when I use ErrorDocument to server custom 404
> pages the 
> output filter I defined is not getting used anymore. Is there some
> special 
> configuration required to make the filters also work on custom error
> pages?

I've noticed that myself. But I think it's actually quite good it doesn't.
Most HTTP clients have a hard time dealing with HTTP as is.
Confusing them with Transfer-Encoding and similar things, while confusing
them with Errors -- that just might be too much.

Now, this is my experience (and speculation) using mod_filter+mod_deflate.
What's your use-case? What's your config? And why do you think you need
filters applied on Errors as well?

Finally, if someone of the Devs is spying, can you explain the reason
behind this reasoning?

> Regards,
>    Dennis

i

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message