httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: [users@httpd] Facing xml/expat problems installing Apache 2.3.8 on Ubuntu 10.10
Date Wed, 01 Dec 2010 13:20:55 GMT
On 28.11.2010 13:11, Igor Galić wrote:
>
> ----- "Sanchit Jain"<sanchitjainjammu@gmail.com>  wrote:
>
>> Hi!
>>
>> I'm facing a problem installing Apache 2.3.8 on Ubuntu.
>
> You are aware of the fact, that this is the current alpha
> release?
>
>> I followed the instructions given on
>> http://httpd.apache.org/docs/2.2/install.html. -
>
> While this is documentation for the current stable.
> Sadly, the apr part of the compile procedure has been
> removed from the documentation.
>
>> # Build and install apr 1.2
>
> I'm not sure if 1.2 is supported at all by alpha.
> I strongly suggest to download -deps.tar.bz2
> http://httpd.apache.org/download.cgi#apache23
>
> If you unpack these deps in the same directory as the
> httpd-2.3.8.tar.bz2, they will end up in
> httpd-2.3.8/src-lib/apr*
>
> Then configure with:
>
>> While installing Apache as it is, i.e. using ./configure
>> --with-included-apr, I get the following error -
>
>
>> configuring package in xml/expat now
>> checking build system type... i686-pc-linux-gnu
>> checking host system type... i686-pc-linux-gnu
>> checking target system type... i686-pc-linux-gnu
>> /home/sanchit/Documents/httpd-2.3.8/srclib/apr-util/xml/expat/configure:
>> line 2417: syntax error near unexpected token `lt_decl_varnames,'
>> /home/sanchit/Documents/httpd-2.3.8/srclib/apr-util/xml/expat/configure:
>> line 2417: `lt_if_append_uniq(lt_decl_varnames, SHELL, , ,'
>> configure failed for xml/expat
>> configure failed for srclib/apr-util
>>
>>
>> The line mentioned in the error is -
>>
>> lt_if_append_uniq(lt_decl_varnames, SHELL, , ,
>>      lt_dict_add_subkey([lt_decl_dict], [SHELL], [libtool_name],
>> 	[m4_ifval([], [], [SHELL])])
>>      lt_dict_add_subkey([lt_decl_dict], [SHELL], [value], [1])
>>      m4_ifval([Shell to use when invoking shell scripts],
>> 	[lt_dict_add_subkey([lt_decl_dict], [SHELL], [description], [Shell
>> to
>> use when invoking shell scripts])])
>>      lt_dict_add_subkey([lt_decl_dict], [SHELL],
>> 	[tagged?], [m4_ifval([], [yes], [no])]))
>>
>>
>> Please tell me how to fix this. Thanks in advnace!
>
> Do you have all the necessary tools installed, as mentioned in
> the installation documentation? m4, libtool, autoconf, automake
>
> Do you have all the basic dependencies installed?
> For expat in Ubuntu this would be libexpat1-dev, as Ubuntu doesn't
> install headerfiles by default.
>
> etc..

In addition to the above: there have been several libtool related fixes 
to the build process in the meantime. If you retry with 2.3.8, use APR 
1.4.2 and APU 1.3.10. Versions 1.2 are older than what we bundle with 
recent 2.2 releases.

We tried to release 2.3.9 as beta, but it failed, mostly because of 
Windows related build failures. We expect to vote on a 2.3.10 in the not 
to distinct future. So if you want to experiment and can wait a bit I 
suggest you wait for the 2.3.10. Note that 2.3.10 will still not be a 
production release.

Regards,

Rainer

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message