httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michelle Konzack <linux4miche...@tamay-dogan.net>
Subject [users@httpd] ProxyPass and problem with VHosts
Date Fri, 24 Dec 2010 03:49:22 GMT
Now it works partialy and requeests are forwarded but there is a problem
with the config.

On the Gateway-Router I have:

----[ '/srv/APACHE_available/www.tdipmedia.net' ]-----------------------
<VirtualHost 192.168.0.69:80>
    ServerAdmin         hostmaster@tamay-dogan.net
    ServerName          www.tdipmedia.net

    ProxyRequests       off
    ProxyVia            on
    ProxyPass           / http://192.168.0.208/
    ProxyPassReverse    / http://192.168.0.208/
    <Proxy *>
        Order           deny,allow
        Allow           from all
    </Proxy>
</VirtualHost>
------------------------------------------------------------------------

and on the Server:

----[ '/srv/APACHE_available/vserver08.tamay-dogan.net' ]---------------
NameVirtualHost 192.168.0.208:80

<VirtualHost 192.168.0.208:80>
    ServerAdmin         hostmaster@tamay-dogan.net
    ServerName          vserver08.tamay-dogan.net

    DocumentRoot        /VServer_08/htdocs/
    <Directory />
        Options         FollowSymLinks Indexes
        AllowOverride   None
    </Directory>
</VirtualHost>
------------------------------------------------------------------------

----[ '/srv/APACHE_available/www.tdipmedia.net' ]-----------------------
<VirtualHost 192.168.0.208:80>
    ServerAdmin         michelle.konzack@tamay-dogan.net
    ServerName          www.tdipmedia.net

    DocumentRoot        /VServer_08/CONFIG_www.tdipmedia.net/htdocs/
    <Directory />
        Options         FollowSymLinks Indexes
        AllowOverride   None
    </Directory>
</VirtualHost>
------------------------------------------------------------------------

Now if I check with an index.php where I am I get always

SERVER_NAME     192.168.0.208
HTTP_HOST       192.168.0.208

and never the requested VHost-Name.
Any requests go to /VServer_08/htdocs/.

How can I correct this?

Note:  I have more then one VHost on it.

Thanks, Greetings and nice Day/Evening
    Michelle Konzack

-- 
##################### Debian GNU/Linux Consultant ######################
   Development of Intranet and Embedded Systems with Debian GNU/Linux

itsystems@tdnet France EURL       itsystems@tdnet UG (limited liability)
Owner Michelle Konzack            Owner Michelle Konzack

Apt. 917 (homeoffice)
50, rue de Soultz                 Kinzigstra├če 17
67100 Strasbourg/France           77694 Kehl/Germany
Tel: +33-6-61925193 mobil         Tel: +49-177-9351947 mobil
Tel: +33-9-52705884 fix

<http://www.itsystems.tamay-dogan.net/>  <http://www.flexray4linux.org/>
<http://www.debian.tamay-dogan.net/>         <http://www.can4linux.org/>

Jabber linux4michelle@jabber.ccc.de

Linux-User #280138 with the Linux Counter, http://counter.li.org/

Mime
View raw message