httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanchit Jain <sanchitjainja...@gmail.com>
Subject [users@httpd] Facing xml/expat problems installing Apache 2.3.8 on Ubuntu
Date Sun, 28 Nov 2010 05:44:47 GMT
Hi!

I'm facing a problem installing Apache 2.3.8 on Ubuntu.

I followed the instructions given on
http://httpd.apache.org/docs/2.2/install.html. -

# Build and install apr 1.2
cd srclib/apr
./configure --prefix=/usr/local/apr-httpd/
make
make install

# Build and install apr-util 1.2
cd ../apr-util
./configure --prefix=/usr/local/apr-util-httpd/
--with-apr=/usr/local/apr-httpd/
make
make install

# Configure httpd
cd ../../
./configure --with-apr=/usr/local/apr-httpd/
--with-apr-util=/usr/local/apr-util-httpd/

However, I'm getting the following error when I try to configure apr-util -

configuring package in xml/expat now
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
/home/sanchit/Documents/httpd-2.3.8/srclib/apr-util/xml/expat/configure:
line 2417: syntax error near unexpected token `lt_decl_varnames,'
/home/sanchit/Documents/httpd-2.3.8/srclib/apr-util/xml/expat/configure:
line 2417: `lt_if_append_uniq(lt_decl_varnames, SHELL, , ,'
configure failed for xml/expat


While installing Apache as it is, i.e. using ./configure
--with-included-apr, I get the following error -

configuring package in xml/expat now
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
/home/sanchit/Documents/httpd-2.3.8/srclib/apr-util/xml/expat/configure:
line 2417: syntax error near unexpected token `lt_decl_varnames,'
/home/sanchit/Documents/httpd-2.3.8/srclib/apr-util/xml/expat/configure:
line 2417: `lt_if_append_uniq(lt_decl_varnames, SHELL, , ,'
configure failed for xml/expat
configure failed for srclib/apr-util


The line mentioned in the error is -

lt_if_append_uniq(lt_decl_varnames, SHELL, , ,
    lt_dict_add_subkey([lt_decl_dict], [SHELL], [libtool_name],
    [m4_ifval([], [], [SHELL])])
    lt_dict_add_subkey([lt_decl_dict], [SHELL], [value], [1])
    m4_ifval([Shell to use when invoking shell scripts],
    [lt_dict_add_subkey([lt_decl_dict], [SHELL], [description], [Shell to
use when invoking shell scripts])])
    lt_dict_add_subkey([lt_decl_dict], [SHELL],
    [tagged?], [m4_ifval([], [yes], [no])]))


Please tell me how to fix this. Thanks in advnace!

Mime
View raw message