httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giannis Palamidaras <palamida...@gmail.com>
Subject [users@httpd] Cannot Start Apache 2.2.x - WSASocket failed to open the inherited socket
Date Fri, 08 Oct 2010 14:26:05 GMT
Hello,

i am desperately trying to make Apache 2.2 service run once again.

I had the latest version of xampp and it worked great.One day,out of sudden
it did not start

I checked the error log and found out that the following error message
appeared:

(OS 10022) An invalid argument was supplied. : Child 452:
setup_inherited_listeners(), WSASocket failed to open the inherited socket

- Reinstalled xampp, uninstalled it , tried Wamp, Apache HTTP Server, Easy
PHP, nothing
- Unistalled antivirus (was installed when Apache was working anyway), shut
down windows firewall, nothing
- Checked ports, the one i used was free (port 80) i changed it anyway to
another port, checked any conflict with skype or other problems,nothing
- Used netdiag to check winsock, winsock is ok
- Unchecked the Enable LMHOSTS in the TCP/IP, nothing
-Google it and checked all possible sugestions

Do you have any suggestions?

Thanks

Giannis

Mime
View raw message