httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roey Almog (Infoneto Ltd)" <al...@infoneto.co.il>
Subject [users@httpd] Perl script are not running on Apache 2.2.15 / mod_fcgid Win32
Date Thu, 14 Oct 2010 20:33:52 GMT
Hi,

I have installed apache 2.2.15 with mod_fcgid on Windows XP SP3 and
tried the perl example script in the mod_fcgid reference page but it
is not working

I get this in error log

[Thu Jul 29 11:26:07 2010] [warn] [client 127.0.0.1] (OS 109)The pipe
has been ended.  : mod_fcgid: get overlap result error
[Thu Jul 29 11:26:07 2010] [error] [client 127.0.0.1] Premature end of
script headers: foo.pl

I double check everything including:
The #!/usr/bin/perl.exe line
The mod_fcgid is loaded

When running the script as plain cgi it works
When I turned to the older mod_fastcgi it works just fine

What can be done ?

I googled around but no one seems to have solution or managed using
mod_fcgid with perl on Win32

I opened a bug on both FCGI at cpan and on apache tracker but no one
seems to care...

Is there a solution for this ?

Roey

Mime
View raw message