httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stevep <ste...@iii.com>
Subject [users@httpd] mod_substitute memory problem
Date Thu, 09 Sep 2010 15:57:58 GMT
We are having a problem where a bad regex in mod_substitute goes into an 
endless loop and keeps allocating more memory, until all of the memory 
on the server is used up.  At that point, telnet is frozen, new telnet 
sessions can not be created, and the only option is to reboot the 
server.  Our setup is Red hat Linux 2.4.21-47.E running on top of VMWare.

Some of these "bad" regexes, have very subtle errors, we test them in 
"regex buddy" before trying them out on the apache server, and still 
create problem regexes.

Some of the problems are less subtle, the following (less subtle) 
example keeps finding /css/ and replacing it in a loop forever.

     AddOutputFilterByType SUBSTITUTE text/html
     Substitute "s|href=\"/css/|href=\"/css/test2/|i"

We tried the RLimitMem directive, but it seems to have no effect on 
mod_substitute.

Does anyone know a way to limit the amount of memory that mod_substitute 
can allocate?



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message