httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Whitson <steven.whit...@gmail.com>
Subject [users@httpd] Can't load driver file apr_dbd_mysql.so
Date Wed, 01 Sep 2010 15:27:20 GMT
  Hi,

I have a freshly built apache server v2.2.16 (exact same error on a 
fresh 2.2.10 too).  When I add the config directive
     DBDriver mysql

I get the following error:
     Can't load driver file apr_dbd_mysql.so

The driver file built ok using the configure directives
      --with-mysql=/usr/local --with-included-apr

Here they are:
./lib/apr-util-1/apr_dbd_mysql-1.so
./lib/apr-util-1/apr_dbd_mysql.so -> apr_dbd_mysql-1.so
./lib/apr-util-1/apr_dbd_mysql.la
./lib/apr-util-1/apr_dbd_mysql.a

I have a couple servers I built a couple years ago which are working 
just fine (2.2.9 & 2.2.10), one on this same sparc system and one on a 
x86 solaris system (both loading this same apr_dbd_mysql driver).  I 
just needed to rebuild this one to support some new features (ssl to 
name one).

Any ideas?  Any help would be greatly appreciated.

This is on a solaris 10 sparc system.

Thanks much,
     -Steve

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message