httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Hadley <jon.had...@gmail.com>
Subject Re: [users@httpd] LDAP authentication behind proxy?
Date Wed, 15 Sep 2010 08:37:34 GMT
On 15 Sep 2010, at 02:52, Eric Covener wrote:
> You defined your trac wsgi stuff outside of the vhosts and the LDAP
> authentication only in one vhost.

Yes, I seemed to get a 'WSGIDaemonProcess' syntax error if the trac wsgi stuff was inside
the second vhost

> I'm guessing the "themeing proxy" is actually accessing a backend
> ip:port other than the one associated with the vhost with
> authentication configured.

It is. There is a Plone CMS system that serves on 8282, which the theming proxy (collective.xdv)
accesses. It deals with LDAP authentication without Apache.

I have tried moving the LDAP authentication within the first vhost, in the theory that the
path name would be challenged there too. It is and authenticates successfully with the LDAP
server, but doesn't get passed successfully to Trac's authentication system.
---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message