httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karthik Nanjangude <karthik.nanjang...@xius-bcgi.com>
Subject [users@httpd] Request to a specific URL Link on one of the web applications is returning "Bad Gateway"
Date Tue, 07 Sep 2010 10:57:18 GMT
Hi

Config Spec
Apache 2.2.1.6
Jboss 4.2.1
mod_jk-1.2.28-httpd-2.2.3.so
Linux Red Hat
DB Oracle


Hosted Application   :  4 apps  [ Independent Containers of  JBOSS Server mapped to Apache
 ]
Logs Configured       : JkLogFile "/apps/logs"   &  JkLogLevel debug

Problem :     Request to a specific URL Link on one of the web applications  is  returning
 "Bad Gateway"
                  Since JBOSS is consuming some time ( 15 sec minimum ) to fetch this  report
 fro Db
How can this problem be fixed.

All other links are displayable correctly



Worker .properties is as follows
worker.list = aloadbalancer, status, sloadbalancer, dloadbalancer, cloadbalancer, mloadbalancer

# Define Node1
# modify the host as your host IP or DNS name.
worker.node1.port=8080
worker.node1.host=10.10.21.170
worker.node1.type=ajp13
worker.node1.lbfactor=1
worker.node1.socket_timeout=10
worker.node1.prepost_timeout=10000
worker.node1.connect_timeout=10000
worker.node1.ping_mode=A


# Load-balancing behaviour
worker.aloadbalancer.type=lb
worker.aloadbalancer.balanced_workers=node1


# Status worker for managing load balancer
worker.status.type=status
worker.list=aloadbalancer,status


with regards

N.S.Karthik


Mime
View raw message