httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Covener <cove...@gmail.com>
Subject Re: [users@httpd] allow autoindex for a directory, but not for its subdirectories
Date Mon, 23 Aug 2010 19:04:27 GMT
On Mon, Aug 23, 2010 at 2:24 PM, Freek Dijkstra <public@macfreek.nl> wrote:
> Eric Covener wrote:
>
>> https://issues.apache.org/bugzilla/show_bug.cgi?id=49809
>>
>> I had looked into this august 2009 and couldn't figure out any good
>> reason why it should be matched as a literal.
>
> Eric,
>
> Thanks for looking into this. It is highly appreciated.
> Is there anything I can do to help?
>
> I did check the source code but I'm afraid I am not familiar enough with
> the Apache internals to help create a patch.
>

The patch is very easy, but I am afraid it might not be suitable to
backport to 2.2.x.

I struggled with finding some fancy PCRE feature that would make this
work as most people expect it to -- \Z or negative lookahead, but
AFAICT they all fail to simulate the $ due to the PCRE flag being
passed.

I started a thread on dev@httpd.apache.org to give people a chance to
complain that DirectoryMatch should behave the way it does, but it
seems so limiting. I will likely commit a fix to trunk tomorrow
morning.


-- 
Eric Covener
covener@gmail.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message