httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Hasicek <martin.hasi...@gmail.com>
Subject Re: [users@httpd] Mythweb Access Forbidden
Date Wed, 25 Aug 2010 16:26:18 GMT
Hi Mark,

my sorry. My english is not so good :-) Try to look here:

http://httpd.apache.org/docs/current/mod/mod_dir.html#directoryindex

and after that find in your configuration directive DirectoryIndex add
mythweb.php there. It should look like:

DirectoryIndex mythweb.php index.html index.php

mh

On Wed, Aug 25, 2010 at 6:21 PM, Mark Adams <madams9@gmail.com> wrote:

> I'm sorry Martin, that makes little sense to me.  This thing is setup by
> defaults to point to /var/www/html/mythweb and execute mythweb.php. It isn't
> supposed to display a file index, so disabling Autoindex seems the way to
> go. I don't think I need DirectoryIndex because I dont' want a directory --
> I want it to execute the mythweb.php script.
>
> Mark
>
>
> On Wed, Aug 25, 2010 at 10:15 AM, Martin Hasicek <martin.hasicek@gmail.com
> > wrote:
>
>> Hi Mark,
>>
>> by directive DirectoryIndex you are enumerate files, which will be listed
>> in case, when client will point only to dorectory. So in case that client
>> will call http://mythweb/ apache will check existence of files enumerated
>> by DirectoryIndex. If it is not able to find them, apache try to do
>> autoindex - display directory in web form.
>>
>> Autoindex is disabled by Options in your configuration and DirectoryIndex
>> is not present in directory. Logical result of it is 403.
>>
>> I hope it will help you.
>>
>> mh
>>
>>
>> On Wed, Aug 25, 2010 at 6:10 PM, Mark Adams <madams9@gmail.com> wrote:
>>
>>>
>>>
>>> On Wed, Aug 25, 2010 at 10:06 AM, Frank Gingras <
>>> francois.gingras@gmail.com> wrote:
>>>
>>>>  On 25/08/2010 12:05 PM, Mark Adams wrote:
>>>>
>>>>> I really hate to bother the group with this issue because my ignorance
>>>>> about
>>>>> apache access is so profound. But here goes.
>>>>>
>>>>> I was attempting to get mythweb accessible from the Internet and just
>>>>> all of
>>>>> a sudden, it was not available (error 403).  I have spent hours editing
>>>>> the
>>>>> hddpd.conf file, the mythweb.conf file, file permissions, implementing
>>>>> and
>>>>> then deimplementing .htaccess files, and everything else I can find.
>>>>> Unfortuanately, I can't get mythweb to show up on any browser on my
>>>>> lan.
>>>>> This after Mythweb ran spectacularly on this system for years. The only
>>>>> thing I can find that seems amiss is that my web server doesn't seem
to
>>>>> support php_value or php_flag.
>>>>>
>>>>> Apache
>>>>> Server version: Apache/2.2.14 (Mandriva Linux/PREFORK-1.5mdv2010.0)
>>>>> Server built:   Aug 16 2010 06:19:58
>>>>>
>>>>> PHP 5.16
>>>>>
>>>>> Mythweb 0.23.1
>>>>>
>>>>> I will be more than happy to point helpers toward httpd.conf , or any
>>>>> other
>>>>> files, at pastbin if it would help.
>>>>>
>>>>> Can anybody tell me anything?
>>>>>
>>>>>  Mark,
>>>>
>>>> What does the error log say, exactly?
>>>>
>>>> Frank
>>>>
>>>>
>>> Thanks for asking Frank. I've got logging turned up to debugging and all
>>> it gives me is this:
>>>
>>> [Wed Aug 25 10:04:06 2010] [error] [client 192.168.1.106] Directory index
>>> forbidden by Options directive: /var/www/html/mythweb/
>>>
>>> I believe this confirms that it's just a misconfig somewhere on my part.
>>> --
>>> Mark Adams
>>>
>>>
>>>
>>
>
>
> --
> Mark Adams
>
>
>

Mime
View raw message