httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CC ...@kdtc.net>
Subject Re: [users@httpd] 2.2.16 and pthread
Date Mon, 30 Aug 2010 02:10:20 GMT
Nick Kew wrote:
>
> On 28 Aug 2010, at 05:11, CC wrote:
>
>> Hi,
>>
>> I just downloaded 2.2.16 and am trying to compile it, but I'm getting
>> an error:
>>
>> /usr/lib/apr-1.3.3/build-1/libtool --silent --mode=link i486-slackware-linux-gcc
-pthread -L/usr/local/ssl/lib -o htpasswd htpasswd.lo -lm /home/compile/httpd-2.2.16/srclib/pcre/libpcre.la
/usr/lib/libaprutil-1.la -ldb-4.4 -lexpat /usr/lib/libapr-1.la -luuid -lrt -lcrypt -lpthread
-ldl
>> /usr/lib/libapr-1.so: undefined reference to `pthread_mutexattr_setprotocol@GLIBC_2.4'
>> /usr/lib/libapr-1.so: undefined reference to `pthread_mutexattr_setrobust_np@GLIBC_2.4'
>> /usr/lib/libapr-1.so: undefined reference to `pthread_mutex_consistent_np@GLIBC_2.4'
>
>
> Have you got multiple versions of some core libraries on there?
>
> It looks as if your /usr/lib/libpthread.so may be incompatible with the version against
> which APR was built.  Possibly you need to reinstall APR, preferably without
> anything C++-ish in the build.  And 'update all' with your package manager first,
> to reduce the likelihood of being hit with similar problems in future!
>

I ended up having to uninstall (or rather remove) old APR, APR-UTIL
packages and then I built/compiled/installed the new APR/APR-UTIl.
I thought since I was upgrading from an old 2.2.6 build, I thought
the requirements were the same.  Apparently it has changed.  My
old APR stuff were of the 1.3.x era.  I d/led the 1.4.x stuff
and installed it.

I think that was what was bugging my build.

Thanks for the help!



Mime
View raw message