httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J. Greenlees" <li...@jaqui-greenlees.net>
Subject Re: [users@httpd] mod_ssl in Apache 2.2.15
Date Mon, 02 Aug 2010 21:00:22 GMT
Jackie.Wong@barclayscapital.com wrote:
> Hi,
> 
> I have downloaded the source of apache 2.2.15 and compiled it with openssl. Then I downloaded
mod_authz_ldap 0.29 from http://authzldap.othello.ch/ and compiled it with no issues. I did
specify apr-1-config, apu-1-config, apxs and openssl when running ./configure. Here is the
command I used:
> 
> ./configure --with-openssl-path=/apache-2.2.15/include/openssl --with-apr=/apache-2.2.15/bin/apr-1-config
--with-apu=/apache-2.2.15/bin/apu-1-config --with-apxs=/apache-2.2.15/bin/apxs
> 
> Then I ran the make command. When it was finished, there was a file called "mod_authz_ldap.so.0.0.0"
created under modules/.lib. I renamed it to mod_authz_ldap.so and copied it to the modules
directory under apache 2.2.15.
> 
> However, when I started httpd, it complained about "undefined symbol: ssl_var_lookup".
I searched on google and this is a function in mod_ssl. I did have the LoadModule line for
mod_ssl before the LoadModule line for mod_authz_ldap in httpd.conf. I assume mod_ssl will
be loaded before mod_authz_ldap. Is this correct? If yes, can someone please advise why it
doesn't work?
> 
> Thanks.
> 
> Regards,
> Jackie

have you installed a certificate for mod_ssl to use for the encryption key?

Jaqui

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message