httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "S. Saberi" <ssab...@hotmail.com>
Subject RE: [users@httpd] mod_rewrite - Error when trying to rewrite one cgi script to another
Date Sat, 10 Jul 2010 02:38:42 GMT

Actually I figured it out finally , I had to set the RewriteBase to /scripts and voila.

 

Thanks for all the feedbacks though set me on the right path.

 

Cheers.
 


From: ssaberi@hotmail.com
To: users@httpd.apache.org
Subject: RE: [users@httpd] mod_rewrite - Error when trying to rewrite one cgi script to another
Date: Fri, 9 Jul 2010 14:28:58 -0700



Hi,
 
Does the log i provided below provide any clues of why my rewrite is failing?  Can a executable
folder in apache be rewritten ad all?  If so can someeone please provide an example? 
 
I have really hit a wall with this.
 
Cheers.
 


From: ssaberi@hotmail.com
To: users@httpd.apache.org
Subject: RE: [users@httpd] mod_rewrite - Error when trying to rewrite one cgi script to another
Date: Wed, 7 Jul 2010 15:08:44 -0700



Alright, finally got the rewrite log to work and here is what it spits out when I attempt
the redirect described earlier:
 
[07/Jul/2010:15:05:07 --0700] [localhost/sid#6b5148][rid#75a040/initial] (3) [perdir C:/Program
Files/Apache Software Foundation/Apache2.2/scripts/] strip per-dir prefix: C:/Program Files/Apache
Software Foundation/Apache2.2/scripts/from.cgi -> from.cgi
[07/Jul/2010:15:05:07 --0700] [localhost/sid#6b5148][rid#75a040/initial] (3) [perdir C:/Program
Files/Apache Software Foundation/Apache2.2/scripts/] applying pattern '^from.cgi' to uri 'from.cgi'
[07/Jul/2010:15:05:07 --0700] [localhost/sid#6b5148][rid#75a040/initial] (2) [perdir C:/Program
Files/Apache Software Foundation/Apache2.2/scripts/] rewrite 'from.cgi' -> 'to.cgi'
[07/Jul/2010:15:05:07 --0700] [localhost/sid#6b5148][rid#75a040/initial] (3) [perdir C:/Program
Files/Apache Software Foundation/Apache2.2/scripts/] add per-dir prefix: to.cgi -> C:/Program
Files/Apache Software Foundation/Apache2.2/scripts/to.cgi
[07/Jul/2010:15:05:07 --0700] [localhost/sid#6b5148][rid#75a040/initial] (1) [perdir C:/Program
Files/Apache Software Foundation/Apache2.2/scripts/] internal redirect with C:/Program Files/Apache
Software Foundation/Apache2.2/scripts/to.cgi [INTERNAL REDIRECT]
 
Looks to me like it is trying to do the right thing. why it is giving a 404 is very puzzling
to me.
 
Hopefully these logs shed some light.
 
Cheers.

 
> Date: Wed, 7 Jul 2010 08:18:23 -0400
> From: covener@gmail.com
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] mod_rewrite - Error when trying to rewrite one cgi script
to another
> 
> On Wed, Jul 7, 2010 at 1:41 AM, S. Saberi <ssaberi@hotmail.com> wrote:
> > actually I just put the directive into the httpd.conf file and i see that
> > the log file is being created upon restart of apache.
> >
> > But when I invokde the rewrite nothing gets logged into it.
> >
> > Any guidance is greatly appreciated.
> >
> 
> It's gotta be in the vhost handling the request, and you need to also
> set RewriteLoglevel to something non-zero (like 9)
> 
> 
> -- 
> Eric Covener
> covener@gmail.com
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> " from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
 		 	   		  
Mime
View raw message