httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "S. Saberi" <ssab...@hotmail.com>
Subject [users@httpd] RE: mod_rewrite - Error when trying to rewrite one cgi script to another
Date Sat, 03 Jul 2010 16:21:21 GMT

Hi all, I really am desperate for an answer on this.  I have been searching forums and reading
up on the documentation, but i have not figured this out yet.

 

Can someone please give me some guidance?  Is my question asked in an incorrect way?  What
can I do to obtain an answer on this.

 

Any feedback is grealy appreciated.

 

Cheers,

Andy
 


From: ssaberi@hotmail.com
To: users@httpd.apache.org
Subject: mod_rewrite - Error when trying to rewrite one cgi script to another
Date: Thu, 1 Jul 2010 22:58:45 -0700



Hi all,

I am getting a 404 error when trying to rewrite one cgi script to another one such as:

Options FollowSymLinks
RewriteEngine on 
RewriteRule ^from.cgi to.cgi

With this rule above my expectaion is that the following url:

mydomain/cgi-bin/from.cgi will be rewritten to mydomain/cgi-bin/to.cgi.

Instead I get the following error in the browser:

"The requested URL /Program Files/Apache Software Foundation/Apache2.2/cgi-bin/to.cgi was
not found on this server."

This is the error in the error.log

"[Thu Jul 01 10:51:57 2010] [error] [client 127.0.0.1] File does not exist: C:/Program Files/Apache
Software Foundation/Apache2.2/htdocs/Program Files"

This is strange as it is referencing the htdocs folder which is not being utulized for this
request.

Any feedback is greatly appreciated.

Cheers,
Andy 		 	   		  
Mime
View raw message