httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "McGranahan, Jamen" <jamen.mcgrana...@Vanderbilt.Edu>
Subject [users@httpd] Solaris 10 / Apache / LDAP
Date Mon, 12 Jul 2010 16:06:33 GMT
I am trying to configure httpd-2.2.15 on a Sun Solaris 10 sparc server with the following options:

./configure CC=gcc --prefix=/opt/pkgs/apache-2.2.15 --enable-access --enable-ssl --with-ssl=/usr/local/ssl
--enable-setenv --enable-so --enable-ldap --with-ldap-lib=/usr/local/lib --with-ldap-include=/usr/local/include
--with-ldap=ldap --enable-authnz_ldap --enable-cgi --enable-rewrite=shared

However, it fails every time with this (last few lines):

checking for ldap support...
  setting APRUTIL_INCLUDES to "-I/usr/local/include"
  setting APRUTIL_LDFLAGS to "-L/usr/local/lib"
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
configure: error: could not find an LDAP library

Before this, I installed openldap-2.4.22, using the package from sunfreeware.com. Libraries
are installed in /usr/local/lib (I checked and verified on another server running 2.2.15 with
ldap support). I did try the information from this page, but received the same result: http://brent.kearneys.ca/2006/12/10/building-ldap-authentication-into-apache2/
 The srclib/apr would install fine. It appears to be a problem with the srclib/apr-util that
is giving me fits and I really don't know why. I even added /usr/local/lib to my LD_LIBRARY_PATH
environment, but still the same result. Any help or guidance would be greatly appreciated.
Thank you!

***********************************
* Jamen McGranahan
* Systems Services Librarian
* Library Information Technology Services
* Vanderbilt University
* GLB, Room 811
* 419 21st Avenue South
* Nashville, TN  37203
* (615) 343-1614
* jamen.mcgranahan@vanderbilt.edu
*
* "to know what is, you can't just be taught it. You must connect with it." -David Warlick
*
***********************************


Mime
View raw message