httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Evans <tevans...@googlemail.com>
Subject Re: [users@httpd] mod_authnz_ldap compile error on Solaris 10
Date Mon, 07 Jun 2010 10:44:04 GMT
On Mon, Jun 7, 2010 at 2:11 AM, Igor Cicimov <icicimov@gmail.com> wrote:
> Hi all,
>
> Wonder if someone has had similar problem compiling apache 2.2.15 source on
> Solaris 10.
>
> ....
> mod_authnz_ldap.c:41:2: #error mod_authnz_ldap requires APR-util to have
> LDAP support built in. To fix add --with-ldap to ./configure.
>...
> and yes I have --with-ldap included in my configure command:
>
> # ./configure --prefix=/usr/local/apache2 --with-mpm=worker --disable-cgid
> --enable-info --enable-proxy --enable-proxy-connect --enable-proxy-ftp
> --enable-proxy-http --enable-proxy-balancer --enable-rewrite
> --enable-headers --enable-cache --enable-mem-cache --enable-disk-cache
> --enable-expires --enable-mods-shared=all --enable-ssl=shared
> --with-ssl=/usr/local/ssl --with-ldap --enable-ldap --enable-authnz-ldap
>
> Thanks,
> Igor
>

I've never used solaris; however that error message is telling you
that apr-util is not built correctly and must be configured with
--with-ldap. Do you have a version of apr already installed?

Cheers

Tom

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message