httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: [users@httpd] Hangs on network hickup
Date Wed, 02 Jun 2010 14:17:08 GMT
2010/6/2 Igor Galić <i.galic@brainsware.org>:
>
> Hello happy people.
>
> I'm experiencing certain troubles with httpd (provided by WebStack 1.5) on Solaris 10

Unless you have a support subscription for that product, build the
latest httpd and php yourself from source.  (Yeah, you'll probably
need to build some add'l support libraries too, but OTOH it is just a
matter of time until you get tired of 2.2.11 and 5.2.9-ish.  (There's
also sunfreeware.com to consider, but I haven't checked available
versions lately.)

> After a network hickup (I suspect) httpd refuses to answer.
> The Process lingers in a state of waiting for the network interface, see the truss below.
> It doesn't recover from this state until after restart.

I don't see the truss in your e-mail.  I wouldn't be at all surprised
if it has a certain familiar pattern, and I could then send you a
library to LD_PRELOAD to work around the problem, but that would just
put off the real solution, which is for you to be in a position to
pick up fixes to httpd, apr, etc.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message