httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ninja <ni...@chadmail.com>
Subject [users@httpd] Can not access one page from other than localhost - but can access another ok from lan...what's up?
Date Sat, 19 Jun 2010 13:53:41 GMT
Hi folks,
   I have just installed nagios and ninja (monitoring apps) on CentOS 5.4 and all appears
to have gone ok, however I have an issue when I try to log in from the LAN, ie not the CenOS
machine(localhost).
  
On the local host, I can open a browser and go to http://192.168.0.11/ninja or http://localhost/ninjaI
enter my userid and pass and I am in. No problems.
 
However, on another machine on the LAN if I go to http://192.168.0.11/ninja it loadshttp://192.168.0.11/ninja/index.php/default/show_login,
 I enter my (same) userid and pass and it just reloads the login screen. No message,no error,
but no login!
 
The odd thing is that I can log into http://192.168.0.11/nagios from the LAN no problems.
But not to /ninja, that only works on the localhost ...I need your help to track the cause.


I looked in the log files and do not see any errors re. the access issue.
 
The /etc/hosts file contains the IP addresses of the LAN machines and the /etc/httpd/conf.d/ninja.conf
file is as follows...
<IfModule !mod_alias.c>
        LoadModule alias_module modules/mod_alias.so
</IfModule>
 
Alias /ninja /usr/local/nagios/addons/ninja
<Directory "/usr/local/nagios/addons/ninja">
        Order allow,deny
        Allow from all
        DirectoryIndex index.php
</Directory>
 
And the /etc/httpd/conf.d/nagios.conf
# SAMPLE CONFIG SNIPPETS FOR APACHE WEB SERVER
# Last Modified: 11-26-2005
#
# This file contains examples of entries that need
# to be incorporated into your Apache web server
# configuration file.  Customize the paths, etc. as
# needed to fit your system.
 
ScriptAlias /nagios/cgi-bin "/usr/local/nagios/sbin"
 
<Directory "/usr/local/nagios/sbin">
#  SSLRequireSSL
   Options ExecCGI
   AllowOverride None
   Order allow,deny
   Allow from all
#  Order deny,allow
#  Deny from all
#  Allow from 127.0.0.1
   AuthName "Nagios Access"
   AuthType Basic
   AuthUserFile /usr/local/nagios/etc/htpasswd.users
   Require valid-user
</Directory>
 
Alias /nagios "/usr/local/nagios/share"
 
<Directory "/usr/local/nagios/share">
#  SSLRequireSSL
   Options None
   AllowOverride None
   Order allow,deny
   Allow from all
#  Order deny,allow
#  Deny from all
#  Allow from 127.0.0.1
   AuthName "Nagios Access"
   AuthType Basic
   AuthUserFile /usr/local/nagios/etc/htpasswd.users
   Require valid-user
</Directory>
 
I do not have a .htaccess file as far as I know.  The above is all on a fresh install of CentOS
5.4.
 
Any and all help appreciated.
 
 
_______________________________________________

Mime
View raw message