httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wang, Mary Y" <mary.y.w...@boeing.com>
Subject RE: [users@httpd] Struggle with Named Virtual Host - The Second Named Virtual HostAlways Returns 404 File Not Found Error
Date Mon, 17 May 2010 03:43:04 GMT
Here is the relevant section:

NameVirtualHost 134.51.151.114:80
<VirtualHost 134.51.151.114:80>
ServerName devbrass2.ana.bna.boeing.com:80
DocumentRoot /usr/brass/www
ServerAdmin mary.y.wang@boeing.com<mailto:mary.y.wang@boeing.com>
ErrorLog logs/error_log
CustomLog logs/access_log combined
LogLevel debug
</VirtualHost>
<VirtualHost 134.51.151.114:80>
ServerName download-devbrass2.ana.bna.boeing.com:80
DocumentRoot /home/project/tsim/htdocs
ServerAdmin mary.y.wang@boeing.com<mailto:mary.y.wang@boeing.com>
ErrorLog logs/error_log
CustomLog logs/access_log combined
LogLevel debug
</VirtualHost>

When I try to access download-devbrass2.ana.bna.boeing.com, I got this error  "Not Found

The requested URL / was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to
handle the request" . /home/project/tsim/htdocs/index.html does exist in that directory. 
When I put this "DocumentRoot /home/project/tsim/htdocs" for devbrass2.ana.bna.boeing.com,
it returned the index.html with no problem at all.  That was why made the conclusion, my virtual
host containers configuration only works for the 1st virtual host container (the default host).

Both devbrass2.ana.bna.boeing.com and download-devbrass2.ana.bna.boeing.com have been registered
as a DNS (download-devbrass2.ana.bna.boeing.com is registered as an alias to devbrass2.ana.bna.boeing.com).

Here is the returned status form apachectl -S:

apachectl -S
/usr/sbin/apachectl: line 33: LD_ASSUME_KERNEL: command not found
VirtualHost configuration:
134.51.151.114:80      is a NameVirtualHost
         default server devbrass2.ana.bna.boeing.com (/etc/httpd/conf/httpd.conf:272)
         port 80 namevhost devbrass2.ana.bna.boeing.com (/etc/httpd/conf/httpd.conf:272)
         port 80 namevhost download-devbrass2.ana.bna.boeing.com (/etc/httpd/conf/httpd.conf:285)
Syntax OK

Thanks in advance.

Mary

________________________________
From: Igor Cicimov [mailto:icicimov@gmail.com]
Sent: Sunday, May 16, 2010 8:04 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Struggle with Named Virtual Host - The Second Named Virtual HostAlways
Returns 404 File Not Found Error

Post the relevant section of the config please so we can help you if you are missing something.

Igor

On Mon, May 17, 2010 at 12:38 PM, Wang, Mary Y <mary.y.wang@boeing.com<mailto:mary.y.wang@boeing.com>>
wrote:
Oh..  apachectl -S shows it's a valid 80 namevhost.  The virtual host name has already been
registered as a DNS (alias).  Just read another post about it, someone mentioned about adding
the name to the /etc/hosts, and that didn't help either.

Still searching for a solution...............

Mary



-----Original Message-----
From: Wang, Mary Y
Sent: Sunday, May 16, 2010 5:58 PM
To: users@httpd.apache.org<mailto:users@httpd.apache.org>
Subject: [users@httpd] Struggle with Named Virtual Host - The Second Named Virtual HostAlways
Returns 404 File Not Found Error

Hi,

I've been struggling with Apache 2 named virtual hosts for a while that I've defined in the
httpd.conf.  The second named virtual host never works, it always returns the 404 file not
found error.  The DocumentRoot I declared for the second named virtual is correct, because
when I put that information in the first named virtual host, it shows up.   After different
tests, I've concluded that anything that I put in the DocumentRoot for the second name virtual
host just always returns the 404 file not found error.  I even commented out a RewriteRule
just to rule of any possibilities, and it still behaves the same.   Has anyone experienced
this problem in Apache 2 before ?  Both the named virtual hosts use the same IP address and
running on port 80.   Is there something out there that I should look for?  I had no problem
in Apache 1.3.7.

Thanks in advance for any inputs.  I thought the migration from 1.3.x to 2 shouldn't take
that long, I guess I underestimated it :-(  .

Mary






---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org<mailto:users-unsubscribe@httpd.apache.org>
  "   from the digest: users-digest-unsubscribe@httpd.apache.org<mailto:users-digest-unsubscribe@httpd.apache.org>
For additional commands, e-mail: users-help@httpd.apache.org<mailto:users-help@httpd.apache.org>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org<mailto:users-unsubscribe@httpd.apache.org>
  "   from the digest: users-digest-unsubscribe@httpd.apache.org<mailto:users-digest-unsubscribe@httpd.apache.org>
For additional commands, e-mail: users-help@httpd.apache.org<mailto:users-help@httpd.apache.org>



Mime
View raw message