httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Cicimov <icici...@gmail.com>
Subject Re: [users@httpd] Apache loadbalancer with tomcat 6
Date Tue, 25 May 2010 00:26:43 GMT
Have you configured the tomcat engine with route=public1 ? I think you
should put something like jvmRoute="public1" in the server.xml file

Igor

On Tue, May 25, 2010 at 1:08 AM, Kevin Castellow <kev.castellow@gmail.com>wrote:

> Is the request actually reaching the Tomcat server?  When using a proxy the
> error from the end point server will also appear in Apache logs as if Apache
> is misconfigured when in reality the 503 may be coming from Tomcat because
> of a misconfiguration there.
>
> Check both logs and see if the request is reaching Tomcat.  It may point to
> more details on the issue.
>
> Kevin
> http://kevincastellow.workintel.com
>
>
> On Mon, May 24, 2010 at 8:00 AM, Nasir Zia <nasir381@gmail.com> wrote:
>
>> Hi,
>>
>> I have configured Apache loadbalancer with tomcat as backend i am getting
>> 503 error in apache logs when accessing tomcat examples context. I have
>> start with one tomcat behind single apache on same machine
>>
>> Here is my httpd conf
>>
>> <VirtualHost *:80>
>>         ServerName abc.com
>>         ProxyRequests Off
>>         <Proxy *>
>>           Order deny,allow
>>           Allow from all
>>         </Proxy>
>>         ProxyPass /balancer-manager !
>>         ProxyPass /examples balancer://mycluster/examples/
>> stickysession=JSESSIONID nofailover=On
>>         ProxyPassReverse /examples ajp://abc.com:8009/examples/
>>         <Proxy balancer://mycluster>
>>           BalancerMember ajp://abc.com:8009/ route=public1
>>           ProxySet lbmethod=byrequests
>>         </Proxy>
>> </VirtualHost>
>>
>>
>
>

Mime
View raw message